Could not find the package with '-<src/sd>' requirements for your system 'windows_amd64'

Hello all, new to this forum. I am not familiar with C++ or Python, or Platformio ro VSCode for that matter. I am very technical though as an old Cobol developer, and the issue I am facing does not make sense.

I am trying to rebuild the Marlin code for my Ender 5 Plus with an SKR V1.4 Turbo board. The last time I built the firmware for this board was back in 2021. I had to make a couple of minor changes and at the same time pulled in the latest version of Marlin and I started to get the following error:

UnknownPackageError: Could not find the package with ‘-<src/sd>’ requirements for your system ‘windows_amd64’

Just as a sanity check, I tried to rebuilt my original 2021 code as well my Ender 3 V2 code, all which worked 2 years ago, and received the same errors for all attempts.

Now, full disclosure, this is a new install of VScode and Platformio on a new desktop, so I might have missed a plugin. I just need help figuring out what I did wrong. I have been trying to figure this out for 3 days and figured it’s time for a lifeline.

This looks like in a line for src_filter (or now named build_src_filter) slipped into lib_deps. Double check your platformio.ini for indentation errors or swapped lines.

Thanks; that worked. Reshuffled the commands and the error is gone.