PlatformIO Community

Could not find a specific package on a computer

Could not find the package with ‘framework-arduinoststm32 @ ~2.1.0’ requirements for your system ‘windows_amd64’.

I have been developing software on the platform. For some reason I uninstalled vscode and on reinstalling it with platform io i get the above error. I have another PC on which there seems to be no error. Both are running the latest version of PIO. I am not sure why it is not able to find it?

Where does it throw that? There is no such package version.

If anything it should reference ~4.20100.0` to get the 2.1 core version.

What is your exact platformio.ini?