Configuration help

Hello, a newbie here.

I want to build a project using ESP32, so I bought Nodemcu’s ESP32 Devkit v1. Now I’m trying to setup a development environment. First I tried an ESP-IDF but it was pretty unusuable, so I deleted .espressiff and esp/esp-idf directories to start again with the PlatformIO. I’ve installed a PlatformIO IDE extension for VSCode and created a new project with a DOIT ESP32 Devkit v1 board with the ESP-IDF framework. After initialization, my project was created, and, as I’ve noticed, the ESP-IDF framework was download to .platformio/packages/framework-espidf/

The problem is - I don’t have any upload or build button in PlatformIO tab. Please help me with my first setup. Thanks in advance.

Can you share a screenshot of your VSCode window?

What other extensions are installed besides PlatformIO and C/C++ by Microsoft?

1 Like


There are the screenshots:

No other extensions are installed

  • Does PIO Home open when click on “PIO Home → Open” in the PlatformIO sidebar?
  • Does opening the platformio.ini make the buttons at the bottom appear?
  • Is the extension enabled in the extensions sidebar → PlatformIO → Cogwheel → Enable?
  • Does this happen with other types of projects, like e.g. Arduino Uno + Arduino, too?
1 Like

Oh god. The tasks appeared after I created another project to check if Arduino is working. But when I try to build a project it fails with this traceback: Traceback (most recent call last): File "/home/uquark/.platformio/packages/fr -

Can you switch to the Arduino project first (using the project switcher mentioned in the last link) and build it to see if that’s working?

The ESP-IDF compilation log looks like something internally fails… due to maybe corrupted files.

raise ParseException("Parsing sections info for library " + + " failed. " + p.message)

pyparsing.ParseException: Expected end of line (at char 24), (line:1, col:25)

You may try and rm -rf ~/.platformio/packages/framework-espidf ~/.platformio/.cache and rebuild the project.

1 Like

Arduino project builds just fine.
After deleting frameworks and cache and rebuilding the project the problem persists

Actually when I look at Build Fails in Python 3.9 (IDFGH-4129) · Issue #5996 · espressif/esp-idf · GitHub it seems to be known, an error handling Unicode symbols in the path though (and also maybe Pyhton 3.9).

Does your project live in a path where there are non-ASCII characters? Your username contains only ASCII characters, too?

Can you try and manually apply the 2 code changes in ~/.platformio/packages/framework-espidf per tools/ldgen: Parse paths with Unicode characters in archives · espressif/esp-idf@f6c8c98 · GitHub in tools/ldgen/ to see if it fixes it?

1 Like

Yeah, the project path contains cyrrilic characters.
I could just rename the directory but I’ll try to patch it.
Thank you.

P. S. Wow. The first time I will patch manually some software on Linux.

1 Like

Thank you, kind man, it worked.

I’ll put this error message here to make this topic easier to find for other people with same issue.

pyparsing.ParseException: Expected end of line (at char 24), (line:1, col:25)

*** [.pio/build/esp32doit-devkit-v1/esp32.project.ld] Error 1

1 Like