Compiling Marlin building error

Hello there,

i’m pretty new to the topic and I’m compiling Marlin for the first time. After 2 days i now figured out that i have to use the Creality V422 configs because i have a V2.2. Motherboard. I’ve been using PIO and
Auto Build Marlin.

But now i’ve got the Error:

“resource”: “/c:/Users/arneh/Downloads/3D Druck/MarlinUpdateBugfix_Richtig/Marlin-2.0.x/Marlin/src/module/motion.cpp”,
“owner”: “C/C++”,
“code”: “20”,
“severity”: 8,
“message”: “Der Bezeichner ““HOMING_FEEDRATE_XY”” ist nicht definiert.”,
“source”: “C/C++”,
“startLineNumber”: 151,
“startColumn”: 5,
“endLineNumber”: 151,
“endColumn”: 15
two times and once for the Z axis and i get the error code:

“resource”: “/c:/Users/arneh/Downloads/3D Druck/MarlinUpdateBugfix_Richtig/Marlin-2.0.x/Marlin/src/module/motion.cpp”,
“owner”: “C/C++”,
“code”: “20”,
“severity”: 8,
“message”: "Der Bezeichner ““PA5"” ist nicht definiert.”,
“source”: “C/C++”,
“startLineNumber”: 1552,
“startColumn”: 10,
“endLineNumber”: 1552,
“endColumn”: 19

for some weird PA5, PA6 and PA7. I#ve got no idea what that means.
If you need something to help me pls tell me where i can find it, i dont rly know what i’m doing :sweat_smile:

Thanks in advance!

You’re citing Microsoft IntelliseSense ‘errors’. What does it say when you build the code? Is it successfull?

Hey :blush:

Sorry for the late reply.

One time i was able to build Marlin but it failed in the upload after trying to send it 10 times (i think it was with the firmware for the wrong board so this doesn’t rly matter). But every other time the process wasn’t succesfull. Meanwhile I’m trying to use different updates of the firmware (2.0.6; 2.0.5; …) from github but in those i cant find the proper V422 file for my V4.2.2 Motherboard…

If you need any special information I’ll give my best to find it and provide it to you :sweat_smile:

You should be using the latest stable marlin or bugfix marlin version as a baseline.

When you’ve downloaded the latest Marlin version, what changes have you done to the platformio.ini and where are the configuration files (Configuration.h / Configuration_adv.h) that you used for the 3D printer?

I tried the bugfix file but i also heared that this can make problems on windows, so the bugfix version wont compile properly. The normal files dont include the right motherboard version for my printer (it’s possible to change this preset in the config but i’m not sure which values i have to change so i dont miss any).

I havent done any changes to the platform.ini, i did some changes in the configuration.h and in the configuration_adv.h in order to make my bltouch work right and do some other adjustments like in this video (Ender 3 (Pro) Upgrades - BLTouch sensor with Marlin 2.0 - YouTube). i got bothe the conf and conf_adv from github from an extra config file with many presets just like for my ender3pro

I kinda followed this guide (Ender 3 (Pro) Marlin 2.0 Upgrade - Updated Version - YouTube) and had the same problem as if there is no bootloader installed but the V4.2.2(mine) and the V4.2.7 board already got a bootloader, so that shouldnt be a problem.

By the way, are you german ? Because of your nickname. Then we could also speak german if this isnt a problem for you :blush:


Here are the configs: GitHub - MarlinFirmware/Configurations at release-
Here is Marlin: GitHub - MarlinFirmware/Marlin at 2.0.x

And which ones are you using there for your “Creality V422”? Closest thing I found there was CrealityV427 but not V422.

Also when I look at e.g. the V4.2.7 motherboard (Creality Silent Mainboard V4.2.7- Offizieller globaler Store) it has an STM32F103RE ARM-type microcontroller on there, the video you’ve linked compiles a firmware for an AVR-type ATMega1284P type MCU – a completely different microcontroller and motherboad.

Can you confirm that when you look at your v4.2.2 motherboard the MCU on there is a STM32F103RE and not a ATMega type chip? Should be the same as here

Thus since the board has a STM32F103RE I’d more expect it to use this PlatformIO / Marlin environment

instead of the sangduino one.

I primarely tried it with the V422 file from the bugfix files (Configurations/config/examples/Creality/Ender-3 Pro at bugfix-2.0.x · MarlinFirmware/Configurations · GitHub) but this one didnt quiet work as i described earlier.

And yes, the mainboard looks the same as in the pic you sent (V4.2.2) and the controller is also the same as you said. It says STM32F103RE on it.

When i compiled the files in Autobuild Marlin it also showed this controller, thats why i didnt rly understand what was the problem.

I really appreciate your effort, thank you :sweat_smile: :blush:

Using that I tried the following

  • download Marlin in the bugfix-2.0.x version (since that is also the version of those configs)
  • extract all the 4 header files in \config\examples\Creality\Ender-3 Pro\CrealityV422 and overwrite the original Configuration.h and related files with them
  • in the platformio.ini, set default_envs = STM32F103RET6_creality,
  • Build → will fail
  • apply fix ULTIPANEL vs IS_ULTIPANEL · Issue #272 · MarlinFirmware/Configurations · GitHub
  • rebuild will fail with other errors, now indicating a mismatch between Marlin configuration file version and the userd marlin version – although both were sourced from bugfix-2.0.x. Strange.

That’s why I’ve opened [BUG] CrealityV422 config from bugfix-2.0.x not compilable with Marlin bugfix-2.0.x · Issue #413 · MarlinFirmware/Configurations · GitHub, let’s see what’ll be written in there.

Thank you so much, I really appreciate that you spend your free time on my problem :blush:

Hopefully someone else has a clue what’s going on there and has a way to fix it.

I thought I’m just missing something obvious :joy::sweat_smile:

Oh, actually I was missing something obvious. I was using an older version of the Marlin bugfix-2.0.x version, hence the compile errors…

Since my internet is crapping out with 40 kByte/s download, I can’t currently quickly redownload Marlin.

If you follow the first 4 steps in the list above, it should actually go through. Tested by the Marlin authors too, in the linked issue.

Ha, it builds indeed.

You should be able to replicate that.

If you throw the generated .\pio\build\STM32F103RET6_creality\firmware-20210207-004732.bin per Configurations/config/examples/Creality/Ender-3 Pro/CrealityV422 at bugfix-2.0.x · MarlinFirmware/Configurations · GitHub on an SD card and plug it into the printer, it should do something.

Oh ok :thinking: :blush:

Unfortunately I can’t test it until tomorrow afternoon. I’ll reply as soon as possible if I could make it work or not (I hope the changes I have to make to use my bltouch won’t mess with anything) . Wish me luck :joy: :grin:

Thank you very much for your effort :blush:

I just tried it, following the steps, and it finally worked :smiley:

Thank you so much, i’d love to hand you a nice cold beer right now :blush:

I really appreciate your work, have a nice day :grin: