Clang installation detection failure


I am new to PlatformIO and just got the blink program working on my Arduino Nano. During the installation process, I followed the instructions for installing clang to the letter, downloading the most recent version for Windows 64 bit from this link (LLVM Download Page) and installing it on my desktop. Every time I ran Atom, I got a message saying along the lines of “Clang is not installed. Please install now, remind me later, or disable the feature”. After reinstalling a few times I gave up and disabled it, but I really want the autocomplete feature. Does anyone have a clue what’s going on here?


Important note: I researched quite a bit online before posting this and didn’t get anything significant other than “adding to build path” - which I have tried but can’t find in the mess of icons and drop-bars.

Please open system terminal (cmd) and provide output of

echo %PATH%
clang --version

Here it is. Did I do something wrong with “clang --version”?

You forgot to add CLANG to a system PATH. See docs: Redirecting...

I followed those instructions to the letter (as I did previously) and the editor still doesn’t autocomplete. I tried searching “Clang” in Install Packages to see if maybe it didn’t install. Results below. Should I install one of these?

Please forget about PIO IDE and Atom for a while. You have a problem with clang on your machine. It should be visible in your cmd. Try to open system terminal cmd and run

clang --version

I recommend to navigate to OS: Control Panel > Programs > Uninstall clang and then install it again following this instruction Redirecting...

This time I uninstalled manually from the control panel rather than through Clang’s uninstall option and everything works now. Thanks!

*** Anyone with similar problems with reinstalling Clang should note that LLVM must be uninstalled from the control panel and NOT via the LLVM re-installation option when running “LLVM-4.0.0-win64” or the like.

The following method is insufficient:

1 Like