PlatformIO Community

Cant install frameworks - Not connected to the Internet

Hi,
I have installed PlatformIO IDE for VSCode on Win10, but am unable to install platforms.
Python is 2.7.13.

In command-prompt I get:
C:>platformio platform frameworks
Error: You are not connected to the Internet

Can this be due to Kaspersky (which I can’t disable)?

Is there any other way to download and install platforms?

Thanks!

Please provide an output from system Terminal cmd

echo %PATH%
echo %PYTHONPATH%
python --version
pip --version
pip list

Output from cmd:

C:>echo %PATH%
C:\Users\aro.platformio\python27;C:\Users\aro.platformio\penv\Scripts;C:\Python36\Scripts;C:\Python36;C:\Python34;C:\Python34\Scripts;C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\Program Files (x86)\jZip;C:\WINDOWS\system32\config\systemprofile.dnx\bin;C:\Program Files\Microsoft DNX\Dnvm;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit;C:\Program Files\Microsoft SQL Server\130\Tools\Binn;C:\Program Files (x86)\GtkSharp\2.12\bin;C:\Program Files\Git\cmd;c:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn;c:\Program Files\Microsoft SQL Server\100\Tools\Binn;c:\Program Files\Microsoft SQL Server\100\DTS\Binn;C:\Program Files (x86)\Pico Technology\PicoScope6;C:\Program Files (x86)\Pico Technology\PicoScope 6 Beta;C:\Program Files (x86)\Skype\Phone;C:\Users\aro.platformio\python27;C:\Users\aro.platformio\penv\Scripts

C:>echo %PYTHONPATH%
C:\Users\aro\Documents\Visual Studio 2015\Projects

C:>python --version
Python 2.7.13

C:>pip --version
pip 9.0.1 from c:\users\aro.platformio\penv\lib\site-packages (python 2.7)

C:>pip list
DEPRECATION: The default format will switch to columns in the future. You can use --format=(legacy|columns) (or define a format=(legacy|columns) in your pip.conf under the [list] section) to disable this warning.
arrow (0.10.0)
bottle (0.12.13)
certifi (2017.7.27.1)
chardet (3.0.4)
click (5.1)
colorama (0.3.9)
idna (2.6)
lockfile (0.12.2)
pip (9.0.1)
platformio (3.5.0a9)
pyserial (3.4)
python-dateutil (2.6.1)
requests (2.18.4)
semantic-version (2.6.0)
setuptools (36.2.7)
six (1.10.0)
urllib3 (1.22)
virtualenv (15.1.0)
wheel (0.29.0)

Do you use a proxy? It seems that we fixed this issue in the latest development version. Please open PIO IDE Terminal in VSCode and type pio upgrade. It should work now.

Hi I am having a similar problem with my VSCode and PIO IDE Terminal (PlatformIO Core, version 5.1.1)

Tool Manager: Installing platformio/tool-avrdude @ ~1.60300.0
Error: You are not connected to the Internet.
PlatformIO needs the Internet connection to download dependent packages or to work with 
PlatformIO Account.

Currently using proxy at workplace, could be the problem but I have already configured htttp_proxy and https_proxy in the settings.json.

If you followed VSCode — PlatformIO latest documentation and it still doesn’t work, have your administrator look at why its blocking stuff.

Thank you @maxgerhardt. I tried first by editing the setting.json it didn’t work. It works now after including HTTP_PROXY & HTTPS_PROXY in the machine’s system variables. :+1:

1 Like