Can't get debug_server with pipe_allowed-mode to run

Hello Pio-Users,

currently I try tweak my debugger settings for openocd-Debug-Server (pio v4.0.0a23).

I looked a little in the sources and found: if there is no debug_port option in my env then
pio trys to run a piogdb command (that I do not have) … and opens a gdb that is not working since the somehow the pipe fails.

With debug_port=localhost:3333 all is fine and I can run a debug sessions.

Anyway I would prefer the “pipe-allowed-mode” since I have a setup with more then one board connected and in this mode I do not need to juggle with port numbers (just with debugger serials).

Here are my settings:

debug_server = $PLATFORMIO_HOME_DIR/packages/tool-openocd/bin/openocd 
#debug_port = localhost:3333

Any help is apreciated, best regards, Axel

PS: Many thanks to all that made it possible to opensourcing the pio-debugger framework :slight_smile:

I made small step forward with pipe-debugging (v4.0.0b2, Linux Ubuntu 16.04 in VirtualBox)

(gdb) source .pioinit

starts the debugging at gdb prompt … anyway I can’t run into a breakpoint.

Strange thing is, if I run gdb manually, then everything including “tab completion” in gdb works perfect.

arm-none-eabi-gdb .... -x .pioinit myfile.elf

This is actually what we do, see code