PlatformIO Community

Cannot run successful build for Marlin firmware.elf

I have been trying to get a successful build for the Marlin Firmware. I keep getting the error:

“Collect2.exe: error: LD returned 1 exit status
***[.pio\build\mega2560\firmware.elf] Error 1”

I get the same error when trying to do it with the marlin firmware configuration I have and with just the vanilla firmware. I have tried researching to find the problem, but most of what I have done has not fixed the problem still.

I have updated Python, removed and reinstalled PlatformIO, ran ‘pio home’ but it says that “PlatformIO Home server is already started in another process” (but I can’t find WHERE that’s at to stop it). I am just at a loss and hope someone can point me in the right direction. Happy to provide any other info needed.

What’s the error message above that?

Fixed in the development branch of PlatformIO Core 6.0. See the solution

1 Like

That worked! Thank you! I didn’t see that in my research. Thank you that fixed the problem!

1 Like