PlatformIO Community

Cannot add new release to NeoPixelBusGfx

Hi,

I have a problem with adding my lib to platformio correctly.
https://github.com/aligator/NeoPixelBusGfx https://platformio.org/lib/show/6835/NeoPixelBusGfx

At first when I registered the lib to platformio it was a fork of Adafruit_NeoMatrix. And because of this the release version 1.1.4 is not from my lib but from the NeoMatrix lib.

I tried different things to add a new release, which contains my code, but no matter what I do it still stays the same.

I tried to

  • create new Tags & Releases on github
  • remove the forking from the lib so that it’s not marked as fork in github
  • switch from library.properties to library.json

What am I missing?

Thank you.
aligator

My only thought on something to check, as the repo and library.json look fine, would be I don’t know if you can go down in version… perhaps push a later version then the one initially registered? Don’t forget to add a new tag if you do.

Otherwise, since it’s been 11 days since you made the version change, it definitely should have been refreshed by the library crawler, so is something for @ivankravets to have a look at…

I don’t think this was necessary… think PIO Registry only looks at the library manifest library.properties/library.json/etc and the github tags, and then other info if the library manifest is lacking in detail.

I’ve just removed 1.1.4 version and re-indexed library.

Does it look well now? https://platformio.org/lib/show/6835/NeoPixelBusGfx

1 Like

Looks good. Thank you!