Building Homie on Win10 fails but works on Linux (Ubuntu)

I’m trying to build Homie-esp8266 on Windows. This worked before the upgrade to pio 4.0.
As a minimal setup, in a new project I have:

platform = espressif8266
board = nodemcuv2
framework = arduino

lib_deps =

This is what I get on Windows:

> pio run -v
Processing nodemcuv2 (platform: espressif8266; board: nodemcuv2; framework: arduino; build_flags: -D PIO_FRAMEWORK_ARDUINO_LWIP2_LOW_MEMORY; lib_deps:; monitor_speed: 115200)
PLATFORM: Espressif 8266 2.2.2 > NodeMCU 1.0 (ESP-12E Module)
HARDWARE: ESP8266 80MHz, 80KB RAM, 4MB Flash
PACKAGES: toolchain-xtensa 2.40802.190218 (4.8.2), tool-esptool 1.413.0 (4.13), tool-esptoolpy 1.20600.0 (2.6.0), framework-arduinoespressif8266 2.20502.0 (2.5.2)
LDF: Library Dependency Finder ->
LDF Modes: Finder ~ chain, Compatibility ~ soft
Found 31 compatible libraries
Scanning dependencies...
Warning: Ignored `ArduinoJson` dependency for `Homie` library
Warning: Ignored `AsyncMqttClient` dependency for `Homie` library
Warning: Ignored `Bounce2` dependency for `Homie` library
Warning: Ignored `ESP Async WebServer` dependency for `Homie` library
Dependency Graph
|-- <Homie> 2.0.0 #edb5d62 [git+] (C:\Users\David\Documents\PlatformIO\Projects\HomieStable\.pio\libdeps\nodemcuv2\Homie@src-e4c79fb15b190bf0db9479b0f4561658)

I’ve truncated this, but it goes on to fail, unable to find AsyncMqttClient.h,
which is reasonable :slightly_smiling_face:
I have tried exactly the same on Ubuntu, and it builds and links fine.
I’m using VS Code, Platformio Home 2.2.0 Core 4.0.2
Any help would be appreciated.

Did you install the dependency libraries in the global lib repository?

What happens when you do it under Windows, i.e. install all lib dependencies manually via the VSCode GUI?

The warning comes from here but I’m not sure which places are searched exactly…

I didn’t do any extra library installation on either Ubuntu or Windows

If I add the dependencies to platformio.ini on Windows, then it works.

lib_deps =
    ESP Async WebServer

I am using ‘Git for Windows’ which has known issue:

  • Some console programs, most notably non-MSYS2 Python, PHP, Node and OpenSSL, interact correctly with MinTTY only when called through winpty (e.g. the Python console needs to be started as winpty python instead of just python ).

Could this upset the Library Dependency Checker? Just clutching here, don’t know what I’m talking about.