Build crashes when adding a custom library

Hi ,
I’m working on a project to use Arducam to take pictures on STM32F429 nucleo board .When I compile Arducam library it crashes like a loop never ends .This happening with the latest build Core 5.0.3. Since I tested same code month ago and I never experience it.

The platform.ini is ,

platform = ststm32
board = nucleo_f429zi
framework = arduino
lib_deps = C:\Users\samson\Desktop\Arducam

Appreciate if someone can help me with this issue .


That looks wrong to me. According to the docs, (scroll down to the end of the “Description” section), it should be:

lib_deps = file://C:\Users\samson\Desktop\Arducam

That should correctly install the library into the project.

Alternatively, change to:

lib_extra_dirs = C:\Users\samson\Desktop

The compile will find Arducam, plus anything else on your desktop that you might have. Desktop might not be the best place though – I’d use a “proper” location for downloaded libraries.



Hi Norm ,

Thanks for the info .I tried your method and it still crashes when compiling .like i said it used to work fine until the latest core update .Not sure if its something related to that .


Meaning compilation never ends, or is an error message thrown? Can you provide a screenshot here if you’re working with VSCode or terminal output? Or are you talking about the execution of the firmware?

Also have you tried updating to the latest dev version by doing pio upgrade --dev and checking if the problem still persists?

Hi Max ,

The compilation never ends as shown in this picture .


Its says building and run like a loop .I tried to update the python to the latest version and uninstall PIO ,install back .

Still the problem exists .Also when i check for errors it shows 156 errors

This never happened before .Not sure if its the latest core .
Also i did upgrade as well still no luck .

Thank you .

Thank you everyone , fixed the problem .The libraries got duplicated somehow and causing this issue .Not sure how it happened but its all good now .

Thanks for your help !

1 Like

I will remove this topic since it will mislead to others .


Hm I wouldn’t delete this because the answer is also written in this thread.

ArduCAM.h includes… ArduCAM.h which includes… ArduCAM.h… o_o