PlatformIO Community

Bricked Wemos d1 mini,visual studio code


#21

Seems like you give up too early. Read https://www.esp8266.com/viewtopic.php?f=6&t=15276. Also you should try to erase the flash using esptool.py -p <comport> erase_flash. What is the error message when you run that command?


#22

i read this topic and tried with bridge and resistros. how much resist it needs>??

C:\Users\hwa_r>esptool.py --port COM6 --baud 115200 erase_flash
esptool.py v2.6
Serial port COM6
Connecting……_____

A fatal error occurred: Failed to connect to Espressif device: Timed out waiting for packet header


#23

Pull-ups/downs are usually 10K in this case. You need to get your ESP8266 into serial bootloader mode somehow. (https://github.com/espressif/esptool/wiki/ESP8266-Boot-Mode-Selection)


#24

it doesnt work. i think that is a a strange case


#25

I found this because I was having trouble uploading to my wemos d1_mini. Connecting D3 to GND, pressing reset, removing D3 from GND then uploading again worked great! Thank you for the info on forcing the bootloader to work :+1:


#26

Okay… So I might have been a bit hasty in my comment. The trick did something. It seemed I could upload finally but I did not get the desired results. Trying an official example project did not work either. The boot loader trick stopped pushing the code through, if it even ever actually worked properly to begin with.

I tried a different wemos d1_mini board just in case… Same issue. I loaded it up in the arduino IDE and it did not work for the first time… Loosing a fair bit of hair at this point. I tried the other usb port option in the arduino ide and it uploaded without any issues.

adding upload_port = /dev/cu.wchusbserial1430 to my original project in platformio.ini produced ZERO ISSUES

Without forcing the upload_port it tries /dev/cu.usbserial-1430 which is wrong, as it does not work.

mac osx mojave 10.14.3
atom 1.35.1
platformio 3.6.5