Archiving problem libFrameworkArduino.a

I use esp32 nodemcu with platformio.
platform = espressif32
board = esp32doit-devkit-v1
framework = arduino
Since 2 days i have a probleme with archivage when i compile. (like this picture)


my code it’s not running, it’s stop after libFrameworkArduino.a

I have tried to create new project and it’s the same.
I have this problem on atom and visual studio code

thank you for helping

  • Have you tried disabling the antivirus software on your computer?
  • Have you tried removing the .pio\ folder of the project and recompiling?

yes i had try both but it’s always the same. It’s stop in this line :
Archiving .pio\build\esp32doit-devkit-v1\libFrameworkArduino.a

Remove you C:\Users\<user>\.platformio\packages\toolchain-xtensa32 folder and retry compilation. Maybe the toolchain has a defect.

Also make sure that you’re running the latest ESP32 platform version (pio platform update) and PlatformIO core itself, both are updatable in the VSCode GUI / PIO sidebar

i have tried to delete toolchain-xtensa32 but nothing happend it’s the same.

i have already update my platform
“You’re up-to-date!
PlatformIO 4.3.4 is currently the newest version available.”

I have tried with other esp32 on this computer it’s not working. But in other computer it’s working so it’s not my code.

What exact operating system and version are you running? (If Windows: Windows+R-> ver -> Enter -> yields something like [Version 10.0.17763.1217])

What Antivirus have you installed on the computer?

i use windows : version 1909 (OS build 18363.836) with linux in dual boot. I compile on windows
but i use this version long time ago and it’s worked.

Norton is installed.

Do you resolve it? I meet same issue, i do not know how to do too.

I also meet same issue, my device is esp32 with 2.9 inch e-paper module, my system is win10 1909 and i use windows defender as anti-virus software. When i use platfirmio to build, the build process looks like freezed on archiving libFrameworkArduino.a, but i use arduino and other esp32 project not find this issue. Could you give me some suggestion? thanks!

By the way, the esp32 e-paper lib is installed by myself on global lib folder.

I am not able to reproduce that behavior, the only tips I had are listed above, plus maybe “waiting for a long time to see if it actually never goes through”.

Did this ever get resolved, i am using platfromio for the first time and it is stuck archiving for over an hour now. if this has not been resolved then i will bin it and vscode as thy appear to be trash.

Have you tried the above suggestions regarding removing C:\Users\<user>\.platformio\packages\ or checking if an antivirus interferes (Hang creating new projects. Hang using pio install - #2 by maxgerhardt)

I am on windows 10 so its windows defender is the only protection i have, don’t know how to tell if this is creating an issue it is not bleating. I have deleted the folder you suggested creating a project was not an issue just the build hangs. Fifteen minutes now so the arduino ide works a lot better for me, i will be patient for an hour. Spent money on a tutorial that pointed me to use this, but if it cant even do a blink sketch then i will delete the lot. Shame it looks quality but if can’t manage something this basic without hasle then…

Just tried this for an arduino uno and there is no problem, is it common to have problems with the ESP architecture? I particularly needed ESP32 for wifi webserver hosting.

The topic above also references ESP32 as the platform that the issue occurs. But as said, no issue on my side oO.

It also neever beated for me but definitely interefed. In my last post the linked topic has a link for adding an exception. Can you give it a shot to make absolutely sure nothing intereferes? As additional process names that should be added to the exception I can also recommend xtensa-esp32-elf-ar.exe (with or without .exe, idk) and xtensa-esp32-elf-gcc.exe and xtensa-esp32-elf-g++.exe.

Also there is the possibility of a more in-depth clean reinstall. It might still be restoring corrupted packages from the C:\Users\<user>\.platformio\.cache folder. So to be sure of that, the reinstall procedure would go:

  • Remove the PlatformIO extension from PlatformIO
  • Close VSCode
  • Remove the entire C:\Users\<user>\.platformio\ folder
  • Reopen VSCode
  • reinstall PlatformIO extension

i also had the same thing using nodemcu esp8266 and while building it stopped at the Archiving line .pio\build\nodemcuv2\libFrameworkArduino.a and took a really long time but I’ve never waited for it to finish. any suggestions? thank you

hi, is your problem solved?
it takes me quite long time already, did not solve…

please give me some ideas if you know how to do it

same problem with esp8266. BUT pio run is working.