AP not Found after arduino framework upgrade

Hi There. I´ve recently upgraded my Arduino Framework in VSCode from 1.x to 2.0.5 and my 2 years development proyect stopped to connect to wifi. After 1 day of trying and trying, i´ve compiled and uploaded the wifi client connect example provided from examples, and coudn´t connect to my AP. Still saying AP not found, and of course my AP is working fine cause i have another 3 iot devices connected to it. Best reggards.

And the WiFi client connect sketch works when you downgrade the framework by setting

platform = espressif32@3.5.0

in the platformio.ini instead of platform = espressif32?

Does the problem occurr in the Arduino IDE with Arduino-ESP32 2.0.5 too? If yes → Issue to Issues · espressif/arduino-esp32 · GitHub

Yes, i´ve downgraded

and it worked. I´ve saw the wifi library with platform = espressif32 is 2.0 and with espressif32@3.5.0 the wifi library is 1.0. But i wish to use the latest version of everythin cause i´m looking for a AsyncWebServer errors, sometimes it Panic when someone load the webpage.


If you can reproduce the issue with the latest Arduino-ESP32 in the Arduino IDE, best to open an issue per above link to have the core people look at it.

Solved. It was an encryption compatibility issue. WiFi 1.0 library has a minimal encryption requirement by default WPA. And WiFi 2.0 library has by default WPA2 minimal requirement. So, my AP was in WPA. I´ve setted my AP in WPA2 and my ESP32 could connect again. BTW, it´s possibly to force the minimal requirement encryption to the station by WiFi.setMinSecurity(WIFI_AUTH_WPA_PSK);
Best Reggards

1 Like