PlatformIO Community

Add ability to disable using .cache folder

The use of the global .cache folder is resulting in numerous “Permission denied” errors when downloading libraries during build (Win10, VSCode, all latest versions).
I have a workaround for this by specifying the cache folder in the platformio.ini like:
cache_dir = .pio/.cache

But it would be nice to have an option to disable the use of this caching all together

If the default .cache path is bad, it might be worth to fix it in the core. Please file an issue at https://github.com/platformio/platformio-core and describe your Windows setup which results in PIO having problems.

Cache is disabled by default. Do you have any issues?

If its disabled by default, where can you enable and disable it?

If it’s the cache setting that I think it is, it’s actually enabled by default, not disabled.

Use the PIO Terminal (1) to either get the current value (3,4) or set it (2).

image