PlatformIO Community

Troubleshooting   PlatformIO IDE


Topic Replies Activity
VSCode (USER) ide 25 August 18, 2018
One platformio.ini for multiple projects 14 October 21, 2019
VSCode Not Showing PIO Toolbar or Menu Options - osMac Sierra/High Sierra 8 October 20, 2019
Help Stm32 bluepill_f103c8 and maple librarys 2 October 17, 2019
Problem upload code to ESP-01S 5 October 16, 2019
Upload error 1 when uploading to Mayfly Data Logger v0.5 1 October 12, 2019
[MBED/SMT32] rtos.h not found 3 October 11, 2019
ESP01 Serial Monitor not showing anything 7 October 6, 2019
Undefined Reference error : After separation of classes 4 October 6, 2019
Upload_port not respected 6 October 4, 2019
Build_flags: -Isomedir option not working 1 October 1, 2019
Build error if time library is installed 7 October 1, 2019
Generate binary for SAMD21 for no bootloader application 1 September 30, 2019
PlatformIO doesn't connect to the device on the first try 1 September 30, 2019
PIo/vsc breaks code when I try to format the source 8 September 24, 2019
ESP32 Version Confusion? -- Sample code doesn't compile easily 3 September 22, 2019
New User - Crash During Firmware Build 4 September 21, 2019
Arduino config flags 3 September 19, 2019
Marlin 2.0 Build Issues with Plaformio Mac 3 September 17, 2019
Sudden task errors 4 September 15, 2019
Relocation truncated to fit 5 September 14, 2019
Setup() and loop() in other files 3 September 13, 2019
Terminal Launches Powershell versus Serial Monitor 5 September 8, 2019
How can I make uploads try multiple times with espota 2 September 6, 2019
'time' not declared in Platformio but works in Arduino IDE 8 September 3, 2019
WebSockets can't find ESP8266WiFi 6 September 3, 2019
Trying to build project fails immediately 11 September 3, 2019
Platformio does not Run after VSCode update 7 August 31, 2019
Beginner question: compiling a library for Arduino in PlatformIO? 11 August 31, 2019
ATTiny 85 - Programming as ISP via USB - How To 5 August 30, 2019