PlatformIO Community

Troubleshooting   Integration


About the Integration category (1)
Issue: Platformio CI throws a lot of "stray in program" on linking time, when using --lib="." (4)
Gitlab CI with local Librarie (2)
Clion errors on ALL F() and ICACHE_FLASH_ATTR macros (2)
STM Studio does not work in the elf file generated by mbed (2)
--init and CMAKE_CURRENT_LIST_DIR? (4)
Autocomplete showing methodinformation (1)
CLion autocompletion not working (4)
VS 2017 on windows 10 (8)
Travis CI and PLATFORMIO_BUILD_FLAGS (2)
Is it possible to have autocompletion, linter, etc. on project' libraries in CLion? (1)
Travis-ci: Add private libraries from /root/libraries/[Folder] (8)
Keep CMakeLists.txt update CMakeListsPrivate.txt (5)
Platformio on GitLab CI fails to install (4)
[n00b] Flash .elf file directly with Qt Creator (4)
Platform.io in vscode (and Atom) issues (1)
LinkIT one board (1)
CLion fails to find include files in lib folder (10)
CLion fails to build project (4)
Set lib_ldf_mode for libraries (library.json only) (2)
Comment out build environment - generates lots of errors (5)
Vim linting (ale) and autocomplete (you complete me) (3)
Confusion surrounding preprocessor build flags / #ifdefs with cmake and clion (4)
Platformio ci libraries not found (2)
Emacs compilation mode (2)
Syntastic plugin for VIM (6)
Specify Path to PlatformIO in Visual Studio Code (2)
Arduino-ESP8266 project in CLion - how to compile project properly? (3)
Eclipse unresolved define (3)
CLion - error: 'nullptr' was not declared in this scope (5)