PlatformIO Community

Troubleshooting


PIO Unit Testing PIO Unit Testing – finds problems early in the development cycle http://docs.platformio.org/en/latest/plus/unit-testing.html PIO Unified Debugger It Simply Works. Easier than ever before! http://docs.platformio.org/en/latest/plus/debugging.html Development Platform Integration Troubleshooting with CI & IDE Integration PlatformIO Core Troubleshooting with PlatformIO Core (CLI) PlatformIO Home PlatformIO IDE Troubleshooting with PlatformIO IDE
Topic Replies Activity
About the Troubleshooting category 1 March 9, 2016
Pip installs to wrong location while using VSCode 1 January 17, 2020
Update latest version of ESP-IDF? 1 January 17, 2020
J-Link upload script with additional bootloader (.hex) file 4 January 17, 2020
ESP32 ADC2 readproblem 5 January 17, 2020
Serial Monitor port is not auto-detected (Upload port is Ok) 7 January 17, 2020
How to change default new project location 12 January 16, 2020
Sh: *: No such file or directory 2 January 16, 2020
Atmega 328 - Internal 8MHZ oscillator - Atmel ICE upload troubles 6 January 15, 2020
Install loop in VSCode 5 January 15, 2020
Custom Toolchain installation 5 January 14, 2020
G++ is not recognized 11 January 13, 2020
Errors when compiling ESP32 code 9 January 13, 2020
Building & Uploading SPIFFS fails Error 3 9 January 13, 2020
PIO Debug with FreeRTOS + libopencm3 1 January 13, 2020
Including a file.h in your project 3 January 13, 2020
Framework cached in build process - how to change it 11 January 12, 2020
VSC: No task to run found 4 January 10, 2020
How to upgrade esptool to 2.8 3 January 10, 2020
STM32 upload stalled via ST-LINK "error writing to flash at address 0x08000000" 4 January 10, 2020
STM32F407VET6 & library USB (mbed) 4 January 9, 2020
Error execute pio init 3 January 9, 2020
Stuck at "Executing Task" when trying to Build Firmware 2 January 9, 2020
Include errors detected 39 January 8, 2020
Changing Python to System Version 6 January 8, 2020
Using newlib with libopencm3 on STM32F103 - linker settings? 15 January 8, 2020
Into the quest for a CubeMX framework 11 January 7, 2020
PIO, VSC can't build, no tasks found 43 January 7, 2020
Why `impure_data` appears on custom build and eats 1K memory? Need fix 2 January 7, 2020
Problems with debugging a Longan Nano with RV-Link 3 January 6, 2020